On Mon, Mar 25, 2013 at 01:31:28PM +0100, Michal Hocko wrote: > On Fri 22-03-13 16:23:48, Naoya Horiguchi wrote: > > Currently migrate_huge_page() takes a pointer to a hugepage to be > > migrated as an argument, instead of taking a pointer to the list of > > hugepages to be migrated. This behavior was introduced in commit > > 189ebff28 ("hugetlb: simplify migrate_huge_page()"), and was OK > > because until now hugepage migration is enabled only for soft-offlining > > which takes only one hugepage in a single call. > > > > But the situation will change in the later patches in this series > > which enable other users of page migration to support hugepage migration. > > They can kick migration for both of normal pages and hugepages > > in a single call, so we need to go back to original implementation > > of using linked lists to collect the hugepages to be migrated. > > If the purpose of this patch is to reduce code duplication then you > should remove migrate_huge_page as it doesn't have any caller anymore. Yes, that makes sense. I'll do this. > [...] > > @@ -1482,12 +1483,20 @@ static int soft_offline_huge_page(struct page *page, int flags) > > unlock_page(hpage); > > > > /* Keep page count to indicate a given hugepage is isolated. */ > > - ret = migrate_huge_page(hpage, new_page, MPOL_MF_MOVE_ALL, > > - MIGRATE_SYNC); > > - put_page(hpage); > > + list_move(&hpage->lru, &pagelist); > > + ret = migrate_pages(&pagelist, new_page, MPOL_MF_MOVE_ALL, > > + MIGRATE_SYNC, MR_MEMORY_FAILURE); > > if (ret) { > > pr_info("soft offline: %#lx: migration failed %d, type %lx\n", > > pfn, ret, page->flags); > > + /* > > + * We know that soft_offline_huge_page() tries to migrate > > + * only one hugepage pointed to by hpage, so we need not > > + * run through the pagelist here. > > + */ > > + putback_active_hugepage(hpage); > > Maybe I am missing something but why we didn't need to call this before > when using migrate_huge_page? migrate_huge_page() does not need list handling before/after the call, because it's defined to migrate only one hugepage, and it has a page as an argument, not list_head. > > + if (ret > 0) > > + ret = -EIO; > > } else { > > set_page_hwpoison_huge_page(hpage); > > dequeue_hwpoisoned_huge_page(hpage); > > diff --git v3.9-rc3.orig/mm/migrate.c v3.9-rc3/mm/migrate.c > > index f69f354..66030b6 100644 > > --- v3.9-rc3.orig/mm/migrate.c > > +++ v3.9-rc3/mm/migrate.c > > @@ -981,6 +981,8 @@ static int unmap_and_move_huge_page(new_page_t get_new_page, > > > > unlock_page(hpage); > > out: > > + if (rc != -EAGAIN) > > + putback_active_hugepage(hpage); > > And why do you put it here? If it is called from migrate_pages then the > caller already does the clean-up (putback_lru_pages). What the caller of migrate_pages() cleans up is the (huge)pages which failed to be migrated. And what the above code cleans up is the source hugepage after the migration succeeds. The latter clean-up code originally existed, but removed in 189ebff28 ("hugetlb: simplify migrate_huge_page()"). This commit cleans up the code based on that there was only one user of hugepage migration, but that's not true any more. So the above hunk is a part of revert of the commit. But it's not a simple revert, because there's one difference between now and before 189ebff28 that we link hugepages in-use to hugepage_activelist. Then we finally come to the above change. Thanks, Naoya > > put_page(new_hpage); > > if (result) { > > if (rc) -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>