On Wed, 23 Jan 2013 14:25:07 +0000 Mel Gorman <mgorman@xxxxxxx> wrote: > On Tue, Jan 22, 2013 at 02:46:59PM -0800, Andrew Morton wrote: > > > > reset_page_last_nid() is poorly named. page_reset_last_nid() would be > > better, and consistent. > > > > Look at this closer, are you sure you want? Why is page_reset_last_nid() > better or more consistent? I was looking at this group: static inline int page_xchg_last_nid(struct page *page, int nid) static inline int page_last_nid(struct page *page) static inline void reset_page_last_nid(struct page *page) IMO the best naming for these would be page_nid_xchg_last(), page_nid_last() and page_nid_reset_last(). > The getter functions for page-related fields start with page (page_count, > page_mapcount etc.) but the setters begin with set (set_page_section, > set_page_zone, set_page_links etc.). For mapcount, we also have > reset_page_mapcount() so to me reset_page_last_nid() is already > consistent. But those schemes make no sense. I don't see any benefit in being consistent with existing inconsistency. It's better to use good naming for new things and to fix up the old things where practical. -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>