On Mon, Mar 10, 2025 at 12:42:06PM -0400, Zi Yan wrote: > > Because of the “Careful” comment. But new_folio->* should be fine, > > since it is the same as new_head. So I probably can replace all > > new_head with new_folio except those VM_BUG_ON_PAGE checks? Why not also the VM_BUG_ON_PAGE check? I mean: > @@ -3364,8 +3364,8 @@ static void __split_folio_to_order(struct folio *folio, int old_order, > /* ->mapping in first and second tail page is replaced by other uses */ > VM_BUG_ON_PAGE(new_nr_pages > 2 && new_head->mapping != TAIL_MAPPING, > new_head); VM_BUG_ON_PAGE(new_nr_pages > 2 && new_folio->mapping != TAIL_MAPPING, new_head); (or we could just ditch the assert entirely; it's not all that useful) > - new_head->mapping = head->mapping; > - new_head->index = head->index + index; > + new_folio->mapping = head->mapping; > + new_folio->index = head->index + index; new_folio->mapping = folio->mapping new_folio->index = folio->index +index; (um, and that index + index looks weird; better name might be just 'i')