On Wed, Feb 26, 2025 at 10:25 AM Lorenzo Stoakes <lorenzo.stoakes@xxxxxxxxxx> wrote: > > On Wed, Feb 26, 2025 at 07:20:50PM +0100, Oleg Nesterov wrote: > > On 02/26, Lorenzo Stoakes wrote: > > > > > > Like I said, Jeff opposes the change. I disagree with him, and agree with you, > > > because this is very silly. > > > > > > But I don't want to hold up this series with that discussion (this is for his > > > sake...) > > > > Neither me, so lets go with VM_SEALED_SYSMAP. > > > > My only objection is that > > > > vm_flags = VM_EXEC|VM_MAYEXEC|VM_DONTCOPY|VM_IO; > > vm_flags |= VM_SEALED_SYSMAP; > > > > looks unnecessarily confusing to me, > > > > vm_flags = VM_EXEC|VM_MAYEXEC|VM_DONTCOPY|VM_IO|VM_SEALED_SYSMAP; > > > > or just > > > > vma = _install_special_mapping(..., > > VM_EXEC|VM_MAYEXEC|VM_DONTCOPY|VM_IO|VM_SEALED_SYSMAP, > > ... > > > > looks more readable. But this is cosmetic/subjective, so I won't argue/insist. > > Agreed. This would be good. > > > > > > Jeff - perhaps drop this and let's return to it in a follow up so this series > > > isn't held up? > > > > Up to you and Jeff. > > > > But this patch looks "natural" to me in this series. > > OK, I mean in that case I'm ok with it as-is, as you confirms there's no > issue, I've looked at the code and there's no issue. > > It was only if we wanted to try the VM_SEALED thing, i.e. _always_ seal > then it'd do better outside of the series as there'd be a discussion about > maybe changing this CONFIG_64BIT thing yada yada. > > > > > Oleg. > > > > Jeff - in that case, do NOT drop this one :P but do please look at the > above style nit. > Ok. > Let's keep things moving... :)