On 17/12/2024 18:11, Zi Yan wrote: > On 17 Dec 2024, at 1:43, Ryan Roberts wrote: > >> On 17/12/2024 04:18, Matthew Wilcox wrote: >>> On Mon, Dec 16, 2024 at 10:20:54PM +0530, Dev Jain wrote: >>>> -static int hpage_collapse_scan_pmd(struct mm_struct *mm, >>>> +static int hpage_collapse_scan_ptes(struct mm_struct *mm, >>> >>> i don't think this is necessary at all. you're scanning a pmd. >>> you might not be scanning in order to collapse to a pmd, but pmd >>> is the level you're scanning at. >>> >> >> Sorry Matthew, I don't really understand this statement. Prior to the change we >> were scanning all PTE entries in a PTE table with the aim of collapsing to a PMD >> entry. After the change we are scanning some PTE entries in a PTE table with the >> aim of collapsing to either to a multi-PTE-mapped folio or a single-PMD-mapped >> folio. >> >> So personally I think "scan_pmd" was a misnomer even before the change - we are >> scanning the ptes. > > But there are still a lot of scan_pmd code in the function, for example, > VM_BUG_ON(address & ~HPAGE_PMD_MASK), _pte < pte + HPAGE_PMD_NR in the function. > These need to be changed along with function renaming. If after the change only > a subset of PTEs are scanned within a PMD, maybe a scan_range parameter can be > added. Oh I see; I think your and Matthew's point is that we are scanning a "PMD-entry's worth of PTEs". Looking at it like that, I guess I understand why "scan_pmd" makes sense. Fair enough. > > Best Regards, > Yan, Zi