On Sat, Dec 14, 2024 at 02:22:41PM -0500, Chuck Lever wrote: > On 12/14/24 12:49 PM, Al Viro wrote: > > On Sat, Dec 14, 2024 at 12:13:30PM -0500, Chuck Lever wrote: > > > > > +/* Cf. find_next_child() */ > > > > > +static struct dentry *find_next_sibling_locked(struct dentry *parent, > > > > > + struct dentry *dentry) > > > > > > > > There might be a better name for this function. > > > > There might be better calling conventions for it, TBH. > > AFAICS, all callers are directly surrounded by grabbing/releasing > > ->d_lock on parent. Why not fold that in, and to hell with any > > mentionings of "locked" in the name... > > I've tried it both ways, couldn't make up my mind. I'll try it again. Single return there, so it's just a single spin_lock() on entry and spin_unlock() on exit... No idea if it'll make coverity any happier, but it would be easier on human readers.