On Mon, 6 Aug 2012 21:37:45 +0800 Hillf Danton <dhillf@xxxxxxxxx> wrote: > On Mon, Aug 6, 2012 at 9:24 PM, Michal Hocko <mhocko@xxxxxxx> wrote: > > On Sat 04-08-12 14:08:31, Hillf Danton wrote: > >> The computation of page offset index is incorrect to be used in scanning > >> prio tree, as huge page offset is required, and is fixed with well > >> defined routine. > >> > >> Changes from v1 > >> o s/linear_page_index/linear_hugepage_index/ for clearer code > >> o hp_idx variable added for less change > >> > >> > >> Signed-off-by: Hillf Danton <dhillf@xxxxxxxxx> > >> --- > >> > >> --- a/arch/x86/mm/hugetlbpage.c Fri Aug 3 20:34:58 2012 > >> +++ b/arch/x86/mm/hugetlbpage.c Fri Aug 3 20:40:16 2012 > >> @@ -62,6 +62,7 @@ static void huge_pmd_share(struct mm_str > >> { > >> struct vm_area_struct *vma = find_vma(mm, addr); > >> struct address_space *mapping = vma->vm_file->f_mapping; > >> + pgoff_t hp_idx; > >> pgoff_t idx = ((addr - vma->vm_start) >> PAGE_SHIFT) + > >> vma->vm_pgoff; > > > > So we have two indexes now. That is just plain ugly! > > > > Two indexes result in less code change here and no change > in page_table_shareable. Plus linear_hugepage_index tells > clearly readers that hp_idx and idx are different. > > Anyway I have no strong opinion to keep > page_table_shareable unchanged, but prefer less changes. Don't be too concerned about the size of a change - it's the end result which matters. If a larger patch results in a better end result, then do the larger patch. Also, please add some details to the changelog: the patch is fixing a bug but we aren't told about the end-user-visible effects of that bug. This is important information. -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>