On 06/05/24 11:32, Sebastian Andrzej Siewior wrote: > On 2024-06-04 17:57:46 [+0200], Daniel Bristot de Oliveira wrote: > > On 6/4/24 16:42, Qais Yousef wrote: > > > - (wakeup_rt && !dl_task(p) && !rt_task(p)) || > > > + (wakeup_rt && !realtime_task(p)) || > > > > I do not like bikeshedding, and no hard feelings... No hard feelings :-) > > > > But rt is a shortened version of realtime, and so it is making *it less* > > clear that we also have DL here. > > Can SCHED_DL be considered a real-time scheduling class as in opposite > to SCHED_BATCH for instance? Due to its requirements it fits for a real > time scheduling class, right? > And RT (as in real time) already includes SCHED_RR and SCHED_FIFO. Yeah I think the usage of realtime to cover both makes sense. I followed your precedence with task_is_realtime(). Anyway. If people really find this confusing, what would make sense is to split them and ask users to call rt_task() and dl_task() explicitly without this wrapper. I personally like it better with the wrapper. But happy to follow the crowd.