On Tue, Apr 30, 2024 at 10:41:01AM -0700, Yosry Ahmed wrote: > On Tue, Apr 30, 2024 at 10:38 AM Shakeel Butt <shakeel.butt@xxxxxxxxx> wrote: > > > > On Tue, Apr 30, 2024 at 01:41:38AM -0700, Yosry Ahmed wrote: > > > On Mon, Apr 29, 2024 at 11:06 PM Shakeel Butt <shakeel.butt@xxxxxxxxx> wrote: > > > > > > [...] > > > > + > > > > +#define NR_MEMCG_NODE_STAT_ITEMS ARRAY_SIZE(memcg_node_stat_items) > > > > +#define NR_MEMCG_STATS (NR_MEMCG_NODE_STAT_ITEMS + ARRAY_SIZE(memcg_stat_items)) > > > > +static int8_t mem_cgroup_stats_index[MEMCG_NR_STAT] __read_mostly; > > > > > > NR_MEMCG_STATS and MEMCG_NR_STAT are awfully close and have different > > > meanings. I think we should come up with better names (sorry nothing > > > comes to mind) or add a comment to make the difference more obvious. > > > > > > > How about the following comment? > > The comment LGTM. I prefer renaming them though if someone can come up > with better names. > I will be posting v4 and will change the name (still thinking about the name) becasuse: > > > > +static void init_memcg_stats(void) > > > > +{ > > > > + int8_t i, j = 0; > > > > + > > > > + /* Switch to short once this failure occurs. */ > > > > + BUILD_BUG_ON(NR_MEMCG_STATS >= 127 /* INT8_MAX */); The above should be MEMCG_NR_STAT instead of NR_MEMCG_STATS.