Re: [RFC] Storing same-filled pages without a zswap_entry

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wed, Mar 20, 2024 at 09:26:43PM -0700, Chris Li wrote:
> On Wed, Mar 20, 2024 at 1:49 PM Yosry Ahmed <yosryahmed@xxxxxxxxxx> wrote:
> >
> > Hey folks,
> >
> > I was looking at cleaning up the same-filled handling code in zswap,
> > when it hit me that after the xarray conversion, the only member of
> > struct zwap_entry that is relevant to same-filled pages is now the
> > objcg pointer.
> >
> > The xarray allows a pointer to be tagged by up to two tags (1 and 3),
> > so we can completely avoid allocating a zswap_entry for same-filled
> > pages by storing a tagged objcg pointer directly in the xarray
> > instead.
> >
> > Basically the xarray would then either have a pointer to struct
> > zswap_entry or struct obj_cgroup, where the latter is tagged as
> > SAME_FILLED_ONE or SAME_FILLED_ZERO.
> >
> > There are two benefits of this:
> > - Saving some memory (precisely 64 bytes per same-filled entry).
> > - Further separating handling of same-filled pages from compressed
> > pages, which results in some nice cleanups (especially in
> > zswap_store()). It also makes further improvements easier (e.g.
> > skipping limit checking for same-filled entries).
> >
> > The disadvantage is obviously the complexity needed to handle two
> > different types of pointers in the xarray, although I think with the
> > correct abstractions this is not a big deal.
> 
> Another idea is we can make the zero fill zswap entry immutable and
> share by different pages. That way it does not depend on the xarray
> pointer tagging. It can share the same code path with existing zero
> fill page handling. Just don't free the zero fill entry.

The only relevant item in zswap_entry for same-filled pages is objcg.
That cannot be shared by different pages anyway. So basically the
immutable zswap entry will just be a magic value that encodes all
zero-filled pages.

If we are all fine with only supporting zero-filled pages, then I don't
see why we should not just store the objcg in the xarray and tag it as
such. In fact, we only need to use one of the two available tags in this
case.

> 
> I want to reserve the zswap xarray tagging for another purpose.

Did you have another purpose in mind? or just for future expansion?

As I mentioned above, if we only support zero-filled pages, we only need
one of the two available tags. Also, this is an in-kernel change so I
think we could always take it back if we really need the tags in the
future.

> 
> Just some food for thought. Might have less complexity because it
> doesn't need to deal with two different kinds of pointers.

I think the complexity is not that much with the right abstractions, but
this is best discussed with actual code imo.

> 
> Chris
> 





[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Bugtraq]     [Linux OMAP]     [Linux MIPS]     [eCos]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux