Re: [PATCH v3 3/6] mm: shrinkers: provide shrinkers with names

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Mon, May 09, 2022 at 11:38:17AM -0700, Roman Gushchin wrote:
> diff --git a/drivers/md/bcache/btree.c b/drivers/md/bcache/btree.c
> index ad9f16689419..c1f734ab86b3 100644
> --- a/drivers/md/bcache/btree.c
> +++ b/drivers/md/bcache/btree.c
> @@ -812,7 +812,7 @@ int bch_btree_cache_alloc(struct cache_set *c)
>  	c->shrink.seeks = 4;
>  	c->shrink.batch = c->btree_pages * 2;
>  
> -	if (register_shrinker(&c->shrink))
> +	if (register_shrinker(&c->shrink, "btree"))
>  		pr_warn("bcache: %s: could not register shrinker\n",
>  				__func__);

These drivers need better names for their shrinkers - there will often be
multiple instances in use on a system and we need to distinguish.

Also, "btree" isn't a good name for the bcache shrinker - "bcache-%pU",
c->set_uuid would be a good name for bcache's shrinker, it'll match up with the
cache set directory in /sys/fs/bcache/.

For others (device mapper, md, etc.) there should be a minor device number you
can reference.




[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Bugtraq]     [Linux OMAP]     [Linux MIPS]     [eCos]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux