1. Enhance generic ioremap to make it more useful. 2. Let's arm64 use GENERIC_IOREMAP to cleanup code. 3. Support HAVE_IOREMAP_PROT on arm64, which enable generic_access_phys(), it is useful when debug(eg, gdb) via access_process_vm device memory infrastructure. v2: - s/addr/phys_addr in ioremap_prot, suggested by Andrew Morton - rename arch_ioremap/iounmap_check to arch_ioremap/iounmad and change return value, per Christoph Hellwig and Andrew Morton - and use 'ifndef arch_ioremap' instead of weak function, per Arnd Bergmann - collect ack/review Kefeng Wang (5): mm: ioremap: Use more sensibly name in ioremap_prot() mm: ioremap: Setup phys_addr of struct vm_struct mm: ioremap: Add arch_ioremap/iounmap() arm64: mm: Convert to GENERIC_IOREMAP arm64: Add HAVE_IOREMAP_PROT support .../features/vm/ioremap_prot/arch-support.txt | 2 +- arch/arm64/Kconfig | 2 + arch/arm64/include/asm/io.h | 20 +++-- arch/arm64/include/asm/pgtable.h | 10 +++ arch/arm64/kernel/acpi.c | 2 +- arch/arm64/mm/hugetlbpage.c | 10 --- arch/arm64/mm/ioremap.c | 85 +++---------------- include/asm-generic/io.h | 16 +++- mm/ioremap.c | 27 ++++-- 9 files changed, 74 insertions(+), 100 deletions(-) -- 2.35.3