On Tue 15-12-20 00:24:30, Pavel Tatashin wrote: > On Mon, Dec 14, 2020 at 9:17 AM Michal Hocko <mhocko@xxxxxxxx> wrote: > > > > On Fri 11-12-20 15:21:38, Pavel Tatashin wrote: > > [...] > > > diff --git a/mm/page_alloc.c b/mm/page_alloc.c > > > index c2dea9ad0e98..4d8e7f801c66 100644 > > > --- a/mm/page_alloc.c > > > +++ b/mm/page_alloc.c > > > @@ -3802,16 +3802,12 @@ alloc_flags_nofragment(struct zone *zone, gfp_t gfp_mask) > > > return alloc_flags; > > > } > > > > > > -static inline unsigned int current_alloc_flags(gfp_t gfp_mask, > > > - unsigned int alloc_flags) > > > +static inline unsigned int cma_alloc_flags(gfp_t gfp_mask, > > > + unsigned int alloc_flags) > > > > Do you have any strong reason to rename? Even though the current > > Yes :) > > > implementation only does something for cma I do not think this is all > > that important. The naming nicely fits with current_gfp_context so I > > would stick with it. > > I am renaming because current->flags is removed from this function, > therefore keeping the name > becomes misleading. This function only addresses cma flag check > without looking at the thread local state now. Fair enough. I still dislike cma being called out explicitly because that is slightly misleading as well. gpf_to_alloc_flags would be more explicit I believe. But I do not want to bikeshed this to death. -- Michal Hocko SUSE Labs