On Fri 11-12-20 15:21:38, Pavel Tatashin wrote: [...] > diff --git a/mm/page_alloc.c b/mm/page_alloc.c > index c2dea9ad0e98..4d8e7f801c66 100644 > --- a/mm/page_alloc.c > +++ b/mm/page_alloc.c > @@ -3802,16 +3802,12 @@ alloc_flags_nofragment(struct zone *zone, gfp_t gfp_mask) > return alloc_flags; > } > > -static inline unsigned int current_alloc_flags(gfp_t gfp_mask, > - unsigned int alloc_flags) > +static inline unsigned int cma_alloc_flags(gfp_t gfp_mask, > + unsigned int alloc_flags) Do you have any strong reason to rename? Even though the current implementation only does something for cma I do not think this is all that important. The naming nicely fits with current_gfp_context so I would stick with it. Other than that the patch looks reasonable. I would just add a comment explaining that current_alloc_flags should be called _after_ current_gfp_context because that one might change the gfp_mask. With that addressed, feel free to add Acked-by: Michal Hocko <mhocko@xxxxxxxx> -- Michal Hocko SUSE Labs