On 19.08.20 14:37, Michal Hocko wrote: > On Wed 19-08-20 12:11:48, David Hildenbrand wrote: >> Already two people (including me) tried to offline subsections, because >> the function looks like it can deal with it. But we really can only >> online/offline full sections (e.g., we can only mark full sections >> online/offline via SECTION_IS_ONLINE). >> >> Add a simple safety net that to document the restriction now. Current users >> (core and powernv/memtrace) respect these restrictions. > > I do agree with the warning because it clarifies our expectations > indeed. Se below for more questions. > >> Cc: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> >> Cc: Michal Hocko <mhocko@xxxxxxxx> >> Cc: Wei Yang <richard.weiyang@xxxxxxxxxxxxxxxxx> >> Cc: Baoquan He <bhe@xxxxxxxxxx> >> Cc: Pankaj Gupta <pankaj.gupta.linux@xxxxxxxxx> >> Cc: Oscar Salvador <osalvador@xxxxxxx> >> Signed-off-by: David Hildenbrand <david@xxxxxxxxxx> >> --- >> mm/memory_hotplug.c | 10 ++++++++++ >> 1 file changed, 10 insertions(+) >> >> diff --git a/mm/memory_hotplug.c b/mm/memory_hotplug.c >> index c781d386d87f9..6856702af68d9 100644 >> --- a/mm/memory_hotplug.c >> +++ b/mm/memory_hotplug.c >> @@ -801,6 +801,11 @@ int __ref online_pages(unsigned long pfn, unsigned long nr_pages, >> int ret; >> struct memory_notify arg; >> >> + /* We can only online full sections (e.g., SECTION_IS_ONLINE) */ >> + if (WARN_ON_ONCE(!nr_pages || >> + !IS_ALIGNED(pfn | nr_pages, PAGES_PER_SECTION))) >> + return -EINVAL; > > This looks looks unnecessarily cryptic to me. Do you want to catch full > section operation that doesn't start at the usual section boundary? If > yes the above doesn't work work unless I am missing something. > > Why don't you simply WARN_ON_ONCE(nr_pages % PAGES_PER_SECTION). > !nr_pages doesn't sound like something interesting to care about or why > do we care? > Also the start pfn has to be section aligned, so we always cover fully aligned sections (e.g., not two partial ones). It's essentially a compressed version of !nr_pages || !IS_ALIGNED(pfn, PAGES_PER_SECTION) || !IS_ALIGN(nr_pages, PAGES_PER_SECTION) which is the same as !nr_pages || pfn % PAGES_PER_SECTION) || nr_pages % PAGES_PER_SECTION or !nr_pages || (pfn | nr_pages) % PAGES_PER_SECTION I consider IS_ALIGNED easier to read than % PAGES_PER_SECTION. I can certainly un-compress, whatever you prefer, thanks. -- Thanks, David / dhildenb