On Sun, Jun 26, 2011 at 06:47:37PM -0400, Rik van Riel wrote: > On 06/24/2011 09:49 AM, Andrea Righi wrote: > > >@@ -114,7 +114,8 @@ SYSCALL_DEFINE(fadvise64_64)(int fd, loff_t offset, loff_t len, int advice) > > ret = 0; > > break; > > case POSIX_FADV_NOREUSE: > >- break; > >+ /* Reduce cache eligibility */ > >+ force = false; > > case POSIX_FADV_DONTNEED: > > if (!bdi_write_congested(mapping->backing_dev_info)) > > filemap_flush(mapping); > > And the same is true here. "force" is just not a very > descriptive name. OK, I'll change the name to "invalidate" in the next version of the patch. Thanks, -Andrea > > >@@ -124,8 +125,8 @@ SYSCALL_DEFINE(fadvise64_64)(int fd, loff_t offset, loff_t len, int advice) > > end_index = (endbyte>> PAGE_CACHE_SHIFT); > > > > if (end_index>= start_index) > >- invalidate_mapping_pages(mapping, start_index, > >- end_index); > >+ __invalidate_mapping_pages(mapping, start_index, > >+ end_index, force); > > break; > > default: > > ret = -EINVAL; > > > -- > All rights reversed -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Fight unfair telecom internet charges in Canada: sign http://stopthemeter.ca/ Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>