> (shmem_read_mapping_page_gfp or shmem_read_cache_page_gfp? Generally > the read_mapping_page functions use the mapping's ->readpage, and the > read_cache_page functions use the supplied filler, so I think > read_cache_page_gfp was slightly misnamed.) What about just shmem_read_page? It's not using the pagecache, so no need for the mapping or cache, and the _gfp really is just a hack because the old pagecache APIs didn't allow to pass the gfp flags. For a new API there's no need for that. > +static inline struct page *shmem_read_mapping_page( > + struct address_space *mapping, pgoff_t index) > +{ > + return shmem_read_mapping_page_gfp(mapping, index, > + mapping_gfp_mask(mapping)); > +} This really shouldn't be in pagemap.h. For now probably in shmem_fs.h -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxxx For more info on Linux MM, see: http://www.linux-mm.org/ . Fight unfair telecom internet charges in Canada: sign http://stopthemeter.ca/ Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>