On Fri, Mar 29, 2019 at 05:36:59PM +0800, Baoquan He wrote: > The input parameter 'phys_index' of memory_block_action() is actually > the section number, but not the phys_index of memory_block. This is > a relict from the past when one memory block could only contain one > section. > > Rename it to start_section_nr. > > Signed-off-by: Baoquan He <bhe@xxxxxxxxxx> > Acked-by: Michal Hocko <mhocko@xxxxxxxx> > Reviewed-by: Rafael J. Wysocki <rafael.j.wysocki@xxxxxxxxx> Reviewed-by: Oscar Salvador <osalvador@xxxxxxx> > --- > drivers/base/memory.c | 7 ++++--- > 1 file changed, 4 insertions(+), 3 deletions(-) > > diff --git a/drivers/base/memory.c b/drivers/base/memory.c > index cb8347500ce2..9ea972b2ae79 100644 > --- a/drivers/base/memory.c > +++ b/drivers/base/memory.c > @@ -231,13 +231,14 @@ static bool pages_correctly_probed(unsigned long start_pfn) > * OK to have direct references to sparsemem variables in here. > */ > static int > -memory_block_action(unsigned long phys_index, unsigned long action, int online_type) > +memory_block_action(unsigned long start_section_nr, unsigned long action, > + int online_type) > { > unsigned long start_pfn; > unsigned long nr_pages = PAGES_PER_SECTION * sections_per_block; > int ret; > > - start_pfn = section_nr_to_pfn(phys_index); > + start_pfn = section_nr_to_pfn(start_section_nr); > > switch (action) { > case MEM_ONLINE: > @@ -251,7 +252,7 @@ memory_block_action(unsigned long phys_index, unsigned long action, int online_t > break; > default: > WARN(1, KERN_WARNING "%s(%ld, %ld) unknown action: " > - "%ld\n", __func__, phys_index, action, action); > + "%ld\n", __func__, start_section_nr, action, action); > ret = -EINVAL; > } > > -- > 2.17.2 > -- Oscar Salvador SUSE L3