On Tue 26-03-19 17:02:27, Baoquan He wrote: > The input parameter 'phys_index' of memory_block_action() is actually > the section number, but not the phys_index of memory_block. Fix it. phys_index is a relict from the past and it indeed denotes the section number which is exported as phys_index via sysfs. start_section_nr would be a better name IMHO but nothing to really bike shed about. > Signed-off-by: Baoquan He <bhe@xxxxxxxxxx> > Cc: Greg Kroah-Hartman <gregkh@xxxxxxxxxxxxxxxxxxx> > Cc: "Rafael J. Wysocki" <rafael@xxxxxxxxxx> Acked-by: Michal Hocko <mhocko@xxxxxxxx> > --- > drivers/base/memory.c | 6 +++--- > 1 file changed, 3 insertions(+), 3 deletions(-) > > diff --git a/drivers/base/memory.c b/drivers/base/memory.c > index cb8347500ce2..184f4f8d1b62 100644 > --- a/drivers/base/memory.c > +++ b/drivers/base/memory.c > @@ -231,13 +231,13 @@ static bool pages_correctly_probed(unsigned long start_pfn) > * OK to have direct references to sparsemem variables in here. > */ > static int > -memory_block_action(unsigned long phys_index, unsigned long action, int online_type) > +memory_block_action(unsigned long sec, unsigned long action, int online_type) > { > unsigned long start_pfn; > unsigned long nr_pages = PAGES_PER_SECTION * sections_per_block; > int ret; > > - start_pfn = section_nr_to_pfn(phys_index); > + start_pfn = section_nr_to_pfn(sec); > > switch (action) { > case MEM_ONLINE: > @@ -251,7 +251,7 @@ memory_block_action(unsigned long phys_index, unsigned long action, int online_t > break; > default: > WARN(1, KERN_WARNING "%s(%ld, %ld) unknown action: " > - "%ld\n", __func__, phys_index, action, action); > + "%ld\n", __func__, sec, action, action); > ret = -EINVAL; > } > > -- > 2.17.2 > -- Michal Hocko SUSE Labs