On Wed 17-10-18 08:07:06, Alexander Duyck wrote: > On 10/17/2018 1:47 AM, Michal Hocko wrote: > > On Mon 15-10-18 13:26:56, Alexander Duyck wrote: [...] > > > diff --git a/include/linux/mm.h b/include/linux/mm.h > > > index bb0de406f8e7..ec6e57a0c14e 100644 > > > --- a/include/linux/mm.h > > > +++ b/include/linux/mm.h > > > @@ -102,8 +102,42 @@ static inline void set_max_mapnr(unsigned long limit) { } > > > * zeroing by defining this macro in <asm/pgtable.h>. > > > */ > > > #ifndef mm_zero_struct_page > > > > Do we still need this ifdef? I guess we can wait for an arch which > > doesn't like this change and then add the override. I would rather go > > simple if possible. > > We probably don't, but as soon as I remove it somebody will probably > complain somewhere. I guess I could drop it for now and see if anybody > screams. Adding it back should be pretty straight forward since it would > only be 2 lines. Let's make it simpler please. If somebody really cares then this is trivial to add later. > > > +#if BITS_PER_LONG == 64 > > > +/* This function must be updated when the size of struct page grows above 80 > > > + * or reduces below 64. The idea that compiler optimizes out switch() > > > + * statement, and only leaves move/store instructions > > > + */ > > > +#define mm_zero_struct_page(pp) __mm_zero_struct_page(pp) > > > +static inline void __mm_zero_struct_page(struct page *page) > > > +{ > > > + unsigned long *_pp = (void *)page; > > > + > > > + /* Check that struct page is either 56, 64, 72, or 80 bytes */ > > > + BUILD_BUG_ON(sizeof(struct page) & 7); > > > + BUILD_BUG_ON(sizeof(struct page) < 56); > > > + BUILD_BUG_ON(sizeof(struct page) > 80); > > > + > > > + switch (sizeof(struct page)) { > > > + case 80: > > > + _pp[9] = 0; /* fallthrough */ > > > + case 72: > > > + _pp[8] = 0; /* fallthrough */ > > > + default: > > > + _pp[7] = 0; /* fallthrough */ > > > + case 56: > > > + _pp[6] = 0; > > > + _pp[5] = 0; > > > + _pp[4] = 0; > > > + _pp[3] = 0; > > > + _pp[2] = 0; > > > + _pp[1] = 0; > > > + _pp[0] = 0; > > > + } > > > > This just hit my eyes. I have to confess I have never seen default: to > > be not the last one in the switch. Can we have case 64 instead or does gcc > > complain? I would be surprised with the set of BUILD_BUG_ONs. > > I can probably just replace the "default:" with "case 64:". I think I have > seen other switch statements in the kernel without a default so odds are it > should be okay. Please do, there shouldn't be any need to obfuscate the code more than necessary. -- Michal Hocko SUSE Labs