On Tue 28-08-18 11:54:33, Zi Yan wrote: > Hi Michal, > > On 28 Aug 2018, at 11:45, Michal Hocko wrote: > > > On Tue 28-08-18 17:42:06, Michal Hocko wrote: > >> On Tue 28-08-18 11:36:59, Jerome Glisse wrote: > >>> On Tue, Aug 28, 2018 at 05:24:14PM +0200, Michal Hocko wrote: > >>>> On Fri 24-08-18 20:05:46, Zi Yan wrote: > >>>> [...] > >>>>>> + if (!pmd_present(pmd)) { > >>>>>> + swp_entry_t entry = pmd_to_swp_entry(pmd); > >>>>>> + > >>>>>> + if (is_migration_entry(entry)) { > >>>>> > >>>>> I think you should check thp_migration_supported() here, since PMD migration is only enabled in x86_64 systems. > >>>>> Other architectures should treat PMD migration entries as bad. > >>>> > >>>> How can we have a migration pmd entry when the migration is not > >>>> supported? > >>> > >>> Not sure i follow here, migration can happen anywhere (assuming > >>> that something like compaction is active or numa or ...). So this > >>> code can face pmd migration entry on architecture that support > >>> it. What is missing here is thp_migration_supported() call to > >>> protect the is_migration_entry() to avoid false positive on arch > >>> which do not support thp migration. > >> > >> I mean that architectures which do not support THP migration shouldn't > >> ever see any migration entry. So is_migration_entry should be always > >> false. Or do I miss something? > > > > And just to be clear. thp_migration_supported should be checked only > > when we actually _do_ the migration or evaluate migratability of the > > page. We definitely do want to sprinkle this check to all places where > > is_migration_entry is checked. > > is_migration_entry() is a general check for swp_entry_t, so it can return > true even if THP migration is not enabled. is_pmd_migration_entry() always > returns false when THP migration is not enabled. > > So the code can be changed in two ways, either replacing is_migration_entry() > with is_pmd_migration_entry() or adding thp_migration_supported() check > like Jerome did. > > Does this clarify your question? Not really. IIUC the code checks for the pmd. So even though is_migration_entry is a more generic check it should never return true for thp_migration_supported() == F because we simply never have those unless I am missing something. is_pmd_migration_entry is much more readable of course and I suspect it can save few cycles as well. -- Michal Hocko SUSE Labs