On Fri 20-07-18 12:03:27, Oscar Salvador wrote: > On Thu, Jul 19, 2018 at 10:52:35PM +0200, Oscar Salvador wrote: > > On Thu, Jul 19, 2018 at 05:15:55PM +0200, Michal Hocko wrote: > > > Your changelog doesn't really explain the motivation. Does the change > > > help performance? Is this a pure cleanup? > > > > Hi Michal, > > > > Sorry to not have explained this better from the very beginning. > > > > It should help a bit in performance terms as we would be skipping those > > condition checks and assignations for zones that do not have any pages. > > It is not a huge win, but I think that skipping code we do not really need to run > > is worh to have. > > > > > The function is certainly not an example of beauty. It is more an > > > example of changes done on top of older ones without much thinking. But > > > I do not see your change would make it so much better. I would consider > > > it a much nicer cleanup if it was split into logical units each doing > > > one specific thing. > > > > About the cleanup, I thought that moving that block of code to a separate function > > would make the code easier to follow. > > If you think that this is still not enough, I can try to split it and see the outcome. > > I tried to split it innto three logical blocks: > > - Substract memmap pages > - Substract dma reserves > - Account kernel pages (nr_kernel_pages and nr_total_pages) No, I do not think this is much better. Why do we need to separate those functions out? I think you are too focused on the current function without a broader context. Think about it. We have two code paths. Early initialization and the hotplug. The two are subtly different in some aspects. Maybe reusing free_area_init_core is the wrong thing and we should have a dedicated subset of this function. This would make the code more clear probably. You wouldn't have to think which part of free_area_init_core is special and what has to be done if this function was to be used in a different context. See my point? -- Michal Hocko SUSE Labs