On 06/15/2018 08:27 AM, Kirill A. Shutemov wrote: > On Fri, Jun 15, 2018 at 01:43:03PM +0000, Dave Hansen wrote: >> On 06/15/2018 05:57 AM, Kirill A. Shutemov wrote: >>>>> +#define _PAGE_CHG_MASK (PTE_PFN_MASK_MAX | _PAGE_PCD | _PAGE_PWT | \ >>>>> _PAGE_SPECIAL | _PAGE_ACCESSED | _PAGE_DIRTY | \ >>>>> _PAGE_SOFT_DIRTY) >>>>> #define _HPAGE_CHG_MASK (_PAGE_CHG_MASK | _PAGE_PSE) >>>> This makes me a bit nervous. We have some places (here) where we >>>> pretend that the KeyID is part of the paddr and then other places like >>>> pte_pfn() where it's not. >>> Other option is to include KeyID mask into _PAGE_CHG_MASK. But it means >>> _PAGE_CHG_MASK would need to reference *two* variables: physical_mask and >>> mktme_keyid_mask. I mentioned this in the commit message. >> >> Why can't it be one variable with a different name that's populated by >> OR'ing physical_mask and mktme_keyid_mask together? > > My point is that we don't need variables at all here. > > Architecture defines range of bits in PTE used for PFN. MKTME reduces the > number of bits for PFN. PTE_PFN_MASK_MAX represents the original > architectural range, before MKTME stole these bits. > > PTE_PFN_MASK_MAX is constant -- on x86-64 bits 51:12 -- regardless of > MKTME support. Then please just rename the make PTE_<SOMETHING>_MASK where <SOMETHING> includes both the concept of a physical address and a MKTME keyID. Just don't call it a pfn if it is not used in physical addressing. >> Whatever you come up with will probably fine, as long as things that are >> called "PFN" or physical address don't also get used for keyID bits. > > We are arguing about macros used exactly once. Is it really so confusing? Yes.