On 06/15/2018 05:57 AM, Kirill A. Shutemov wrote: >>> +#define _PAGE_CHG_MASK (PTE_PFN_MASK_MAX | _PAGE_PCD | _PAGE_PWT | \ >>> _PAGE_SPECIAL | _PAGE_ACCESSED | _PAGE_DIRTY | \ >>> _PAGE_SOFT_DIRTY) >>> #define _HPAGE_CHG_MASK (_PAGE_CHG_MASK | _PAGE_PSE) >> This makes me a bit nervous. We have some places (here) where we >> pretend that the KeyID is part of the paddr and then other places like >> pte_pfn() where it's not. > Other option is to include KeyID mask into _PAGE_CHG_MASK. But it means > _PAGE_CHG_MASK would need to reference *two* variables: physical_mask and > mktme_keyid_mask. I mentioned this in the commit message. Why can't it be one variable with a different name that's populated by OR'ing physical_mask and mktme_keyid_mask together? My issue here is that it this approach adds confusion around the logical separation between physical address and the bits immediately above the physical address in the PTE that are stolen for the keyID. Whatever you come up with will probably fine, as long as things that are called "PFN" or physical address don't also get used for keyID bits.