On Sun, May 20, 2018 at 10:42:36PM -0600, Ross Zwisler wrote: > > -static void *dax_radix_locked_entry(unsigned long pfn, unsigned long flags) > > +static void *dax_mk_locked(unsigned long pfn, unsigned long flags) > > Let's continue to use whole words in function names instead of abbreviations > for readability. Can you please s/dax_mk_locked/dax_make_locked/ ? > > I do realize that the xarray function is xa_mk_value() (which I also think is > perhaps too brief for readability), but in the rest of DAX we use full words > everywhere. I find the current DAX code to be _so_ wordy that it obscures readability. This particular instance isn't a hill worth dying on; I'll change it. > > @@ -1519,15 +1517,14 @@ int dax_iomap_fault(struct vm_fault *vmf, enum page_entry_size pe_size, > > } > > EXPORT_SYMBOL_GPL(dax_iomap_fault); > > > > -/** > > +/* > > Let's leave the double ** so that the function is picked up properly by > the documentation system, and so it's consistent with the rest of the > functions. This function is static. I think it's worth keeping the documentation, but making it part of the exported kernel API documentation is confusing. By the way, nothing at all in fs/dax.c is picked up by the documentation system today. We should probably fix that ... did you want to look at it or shall I propose a patch to anchor it somewhere?