On Wed, Feb 07, 2018 at 10:57:28AM +0300, Kirill Tkhai wrote: > On 07.02.2018 08:02, Paul E. McKenney wrote: > > On Tue, Feb 06, 2018 at 08:23:34PM -0800, Matthew Wilcox wrote: > >> On Tue, Feb 06, 2018 at 06:17:03PM -0800, Paul E. McKenney wrote: > >>> So it is OK to kvmalloc() something and pass it to either kfree() or > >>> kvfree(), and it had better be OK to kvmalloc() something and pass it > >>> to kvfree(). > >>> > >>> Is it OK to kmalloc() something and pass it to kvfree()? > >> > >> Yes, it absolutely is. > >> > >> void kvfree(const void *addr) > >> { > >> if (is_vmalloc_addr(addr)) > >> vfree(addr); > >> else > >> kfree(addr); > >> } > >> > >>> If so, is it really useful to have two different names here, that is, > >>> both kfree_rcu() and kvfree_rcu()? > >> > >> I think it's handy to have all three of kvfree_rcu(), kfree_rcu() and > >> vfree_rcu() available in the API for the symmetry of calling kmalloc() > >> / kfree_rcu(). > >> > >> Personally, I would like us to rename kvfree() to just free(), and have > >> malloc(x) be an alias to kvmalloc(x, GFP_KERNEL), but I haven't won that > >> fight yet. > > > > But why not just have the existing kfree_rcu() API cover both kmalloc() > > and kvmalloc()? Perhaps I am not in the right forums, but I am not hearing > > anyone arguing that the RCU API has too few members. ;-) > > People, far from RCU internals, consider kfree_rcu() like an extension > of kfree(). And it's not clear it's need to dive into kfree_rcu() comments, > when someone is looking a primitive to free vmalloc'ed memory. Seems like a relatively simple lesson to teach. > Also, construction like > > obj = kvmalloc(); > kfree_rcu(obj); > > makes me think it's legitimately to use plain kfree() as pair bracket to kvmalloc(). So it all works as is, then. > So the significant change of kfree_rcu() behavior will complicate stable backporters > life, because they will need to keep in mind such differences between different > kernel versions. If I understood your construction above, that significant change in kfree_rcu() behavior has already happened. > It seems if we are going to use the single primitive for both kmalloc() > and kvmalloc() memory, it has to have another name. But I don't see problems > with having both kfree_rcu() and kvfree_rcu(). I see problems. We would then have two different names for exactly the same thing. Seems like it would be a lot easier to simply document the existing kfree_rcu() behavior, especially given that it apparently already works. The really doesn't seem to me to be worth a name change. Thanx, Paul -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>