On Tue, Feb 06, 2018 at 11:54:09PM -0800, Josh Triplett wrote: > On Tue, Feb 06, 2018 at 09:02:00PM -0800, Paul E. McKenney wrote: > > On Tue, Feb 06, 2018 at 08:23:34PM -0800, Matthew Wilcox wrote: > > > On Tue, Feb 06, 2018 at 06:17:03PM -0800, Paul E. McKenney wrote: > > > > So it is OK to kvmalloc() something and pass it to either kfree() or > > > > kvfree(), and it had better be OK to kvmalloc() something and pass it > > > > to kvfree(). > > > > > > > > Is it OK to kmalloc() something and pass it to kvfree()? > > > > > > Yes, it absolutely is. > > > > > > void kvfree(const void *addr) > > > { > > > if (is_vmalloc_addr(addr)) > > > vfree(addr); > > > else > > > kfree(addr); > > > } > > > > > > > If so, is it really useful to have two different names here, that is, > > > > both kfree_rcu() and kvfree_rcu()? > > > > > > I think it's handy to have all three of kvfree_rcu(), kfree_rcu() and > > > vfree_rcu() available in the API for the symmetry of calling kmalloc() > > > / kfree_rcu(). > > > > > > Personally, I would like us to rename kvfree() to just free(), and have > > > malloc(x) be an alias to kvmalloc(x, GFP_KERNEL), but I haven't won that > > > fight yet. > > > > But why not just have the existing kfree_rcu() API cover both kmalloc() > > and kvmalloc()? Perhaps I am not in the right forums, but I am not hearing > > anyone arguing that the RCU API has too few members. ;-) > > I don't have any problem with having just `kvfree_rcu`, but having just > `kfree_rcu` seems confusingly asymmetric. I don't understand why kmalloc()/kvfree_rcu() would seem any less asymmetric than kvmalloc()/kfree_rcu(). > (Also, count me in favor of having just one "free" function, too.) We agree on that much, anyway. ;-) Thanx, Paul -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>