On Wed, 28 Dec 2016 20:16:56 -0800 Linus Torvalds <torvalds@xxxxxxxxxxxxxxxxxxxx> wrote: > On Wed, Dec 28, 2016 at 8:08 PM, Nicholas Piggin <npiggin@xxxxxxxxx> wrote: > > > > Okay. The name could be a bit better though I think, for readability. > > Just a BUILD_BUG_ON if it is not constant and correct bit numbers? > > I have a slightly edited patch - moved the comments around and added > some new comments (about both the sign bit, but also about how the > smp_mb() shouldn't be necessary even for the non-atomic fallback). That's a good point -- they're in the same byte, so all architectures will be able to avoid the extra barrier regardless of how the primitives are implemented. Good. > > I also did a BUILD_BUG_ON(), except the other way around - keeping it > about the sign bit in the byte, just just verifying that yes, > PG_waiters is that sign bit. Yep. I still don't like the name, but now you've got PG_waiters commented there at least. I'll have to live with it. If we get more cases that want to use a similar function, we might make a more general primitive for architectures that can optimize these multi bit ops better than x86. Actually even x86 would prefer to do load ; cmpxchg rather than bitop ; load for the cases where condition code can't be used to check result. > > > BTW. I just notice in your patch too that you didn't use "nr" in the > > generic version. > > And I fixed that too. > > Of course, I didn't test the changes (apart from building it). But > I've been running the previous version since yesterday, so far no > issues. It looks good to me. Thanks, Nick -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>