On Thu, 1 Apr 2010, Oleg Nesterov wrote: > > That doesn't work for depraceted_mode (sic), you'd need to test for > > OOM_ADJUST_MIN and OOM_ADJUST_MAX in that case. > > Yes, probably "if (depraceted_mode)" should do more checks, I didn't try > to verify that MIN/MAX are correctly converted. I showed this code to explain > what I mean. > Ok, please cc me on the patch, it will be good to get rid of the duplicate code and remove oom_adj from struct signal_struct. > > There have been efforts to reuse as much of this code as possible for > > other sysctl handlers as well, you might be better off looking for > > David, sorry ;) Right now I'd better try to stop the overloading of > ->siglock. And, I'd like to shrink struct_signal if possible, but this > is minor. > Do we need ->siglock? Why can't we just do struct sighand_struct *sighand; struct signal_struct *sig; rcu_read_lock(); sighand = rcu_dereference(task->sighand); if (!sighand) { rcu_read_unlock(); return; } sig = task->signal; ... load/store to sig ... rcu_read_unlock(); instead? -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxxx For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>