Re: [PATCH v3 6/7] ACPI: bus: implement acpi_device_hid when !ACPI

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Em Wed, 11 Dec 2024 07:57:06 +0000
Sakari Ailus <sakari.ailus@xxxxxxxxxxxxxxx> escreveu:

> Hi Ricardo,
> 
> On Tue, Dec 10, 2024 at 11:35:35PM +0100, Ricardo Ribalda wrote:
> > On Tue, 10 Dec 2024 at 22:01, Sakari Ailus <sakari.ailus@xxxxxxxxxxxxxxx> wrote:  
> > >
> > > Hi Ricardo,
> > >
> > > On Tue, Dec 10, 2024 at 07:56:03PM +0000, Ricardo Ribalda wrote:  
> > > > Provide an implementation of acpi_device_hid that can be used when
> > > > CONFIG_ACPI is not set.
> > > >
> > > > Signed-off-by: Ricardo Ribalda <ribalda@xxxxxxxxxxxx>
> > > > ---
> > > >  include/acpi/acpi_bus.h | 5 +++++
> > > >  1 file changed, 5 insertions(+)
> > > >
> > > > diff --git a/include/acpi/acpi_bus.h b/include/acpi/acpi_bus.h
> > > > index 4f1b3a6f107b..c25914a152ee 100644
> > > > --- a/include/acpi/acpi_bus.h
> > > > +++ b/include/acpi/acpi_bus.h
> > > > @@ -1003,6 +1003,11 @@ static inline int unregister_acpi_bus_type(void *bus) { return 0; }
> > > >
> > > >  static inline int acpi_wait_for_acpi_ipmi(void) { return 0; }
> > > >
> > > > +static inline const char *acpi_device_hid(struct acpi_device *device)
> > > > +{
> > > > +     return "";
> > > > +}  
> > >
> > > I wonder if any caller might expect something of a string if provided?
> > > Valid _HIDs are either 7 or 8 characters whereas the proper version of the
> > > function returns "device" when one cannot be found (dummy_hid in
> > > drivers/acpi/scan.c). Unlikely to be a problem perhaps.  
> > 
> > Good point. I changed it to return "device"  
> 
> When ACPI is disabled, it's unlikely that string would be used anyway, vs.
> the case when ACPI is enabled but there's no _HID. So I think an empty
> string should be fine. I wonder what others think.
> 
Returning "" also caused me some attention at the original patch. IMO,
placing a pseudo-valid HID would be better, but I guess "device" is also
invalid, as, at least I always saw HIDs in uppercase. Also, I guess it
is always a vendor ID + a 4 digit number.

so, IMHO, something like "DEVC9999" would be a better name if we fill it.

Thanks,
Mauro




[Index of Archives]     [Linux Input]     [Video for Linux]     [Gstreamer Embedded]     [Mplayer Users]     [Linux USB Devel]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [Yosemite Backpacking]

  Powered by Linux