On Wed, Nov 03, 2010 at 01:15:30PM +0100, David Härdeman wrote: > On Tue, 2 Nov 2010 17:12:14 -0400, Jarod Wilson <jarod@xxxxxxxxxx> wrote: > > On Fri, Oct 29, 2010 at 09:21:21PM +0200, David Härdeman wrote: > >> I think the driver could be further simplified by using > >> ir_raw_event_store_with_filter(), right? > > > > And in fact, it is. I've got a new series of patches redone atop your > > rc-core patch series that includes usage of _with_filter in mceusb. > > From a quick check, I think the entire PARSE_IRDATA block in > mceusb_process_ir_data() could be simplified to: > > case PARSE_IRDATA: > ir->rem--; > rawir.pulse = !!(ir->buf_in[i] & MCE_PULSE_BIT); > rawir.duration = (ir->buf_in[i] & MCE_PULSE_MASK) > * MCE_TIME_UNIT * 1000; > ir_raw_event_store_with_filter(ir->rc, &rawir); > break; > > And you can then remove "struct ir_raw_event rawir" from struct > mceusb_dev. Once again, I think you're correct. :) I'll give this a spin with a few mceusb devices, but it does certainly look like that'll work, now that we're using _with_filter. -- Jarod Wilson jarod@xxxxxxxxxx -- To unsubscribe from this list: send the line "unsubscribe linux-media" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html