Hi Laurent, On Thu, Apr 27, 2023 at 08:36:21PM +0300, Laurent Pinchart wrote: > > > > - struct list_head asd_list; > > > > - struct list_head waiting; > > > > - struct list_head done; > > > > - struct list_head list; > > > > + struct list_head asd_head; > > > > + struct list_head waiting_head; > > > > + struct list_head done_head; > > > > + struct list_head notifier_list; > > > > > > I find the _head suffix to still be confusing. How about the following ? > > > > > > struct { > > > struct list_head all; > > > struct list_head waiting; > > > struct list_head done; > > > } asds; > > > > There are many list heads and entries in v4l2-async related structs and > > before this patch. _head is used for all list heads, _list for list > > entries. I prefer having _head as this way it is trivial to look for all > > instances of that list head, removing the _head part makes this much > > harder. > > > > How about using _entry for list entries instead? > > I like that. I would have used _entry for the list entries, and _list > for the list "heads". I don't like the _head suffix very much, as all of > them are struct list_head instances. I won't nack the series for this > though :-) I'm fine with "_list" suffix for list heads, I happened to choose "_head" when writing the set. It's trivial to change that. -- Regards, Sakari Ailus