Hi, On 1/23/23 19:23, Andy Shevchenko wrote: > On Mon, Jan 23, 2023 at 01:51:36PM +0100, Hans de Goede wrote: >> The following drivers under drivers/media/i2c: ov08x40.c, ov13858.c, >> ov13b10.c, ov2680.c, ov2685.c, ov2740.c, ov4689.c, ov5670.c, >> ov5675.c, ov5695.c, ov8856.c, ov9282.c and ov9734.c, >> >> as well as various "atomisp" sensor drivers in drivers/staging, *all* >> use register access helpers with the following function prototypes: >> >> int ovxxxx_read_reg(struct ovxxxx_dev *sensor, u16 reg, >> unsigned int len, u32 *val); >> >> int ovxxxx_write_reg(struct ovxxxx_dev *sensor, u16 reg, >> unsigned int len, u32 val); >> >> To read/write registers on Omnivision OVxxxx image sensors wich expect >> a 16 bit register address in big-endian format and which have 1-3 byte >> wide registers, in big-endian format (for the higher width registers). >> >> Add a new ovxxxx_16bit_addr_reg_helpers.h header file with static inline >> versions of these register access helpers, so that this code duplication >> can be removed. > > > A couple more comments. > > ... > >> +#define ovxxxx_write_reg8(s, r, v) ovxxxx_write_reg(s, r, 1, v) >> +#define ovxxxx_write_reg16(s, r, v) ovxxxx_write_reg(s, r, 2, v) >> +#define ovxxxx_write_reg24(s, r, v) ovxxxx_write_reg(s, r, 3, v) > > Btw, we probably can use _Generic() for these... > > ... > >> +static inline int ovxxxx_mod_reg(struct i2c_client *client, u16 reg, u8 mask, u8 val) > > Can we actually s/mod/update/ as it's more regular when we talk about IO > accessor APIs? Ack, I'll replace the mod with update. Regards, Hans