On Thu, 2010-09-02 at 22:56 +0200, David Härdeman wrote: > On Mon, Aug 30, 2010 at 11:52:26AM +0300, Maxim Levitsky wrote: > > Add new event types for timeout & carrier report > > Move timeout handling from ir_raw_event_store_with_filter to > > ir-lirc-codec, where it is really needed. > > Yes, but it still might make more sense to keep the timeout handling in > ir_raw_event_store_with_filter so that all decoders get the same data > from rc-core? I don't want any timeouts in rc-core. There is just an IR packet that starts optionally with a reset and ends with a timeout bit. I have also nothing against renaming reset/timeout to start/stop. rc-core really shouldn't care about consistent pulse/space ordering. Its lirc that needs it. Also in the future I think I should make the ir_raw_event_store_with_filter the default submit function for all drivers, and then I could drop that silly '_with_filter" thing (Couldn't think for a better name for this function...) > > > Now lirc bridge ensures proper gap handling. > > Extend lirc bridge for carrier & timeout reports > > > > Note: all new ir_raw_event variables now should be initialized > > like that: > > struct ir_raw_event ev = ir_new_event; > > Wouldn't DEFINE_RAW_EVENT(ev); be more in line with the kernel coding > style? (cf. DEFINE_MUTEX, DEFINE_SPINLOCK, etc). Of course, nothing against that. Best regards, Maxim Levitsky -- To unsubscribe from this list: send the line "unsubscribe linux-media" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html