Re: [PATCH] media: use swap() to make code cleaner

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi Kieran,

Both of  yang.guang5@xxxxxxxxxx and davidcomponentone@xxxxxxxxx are
mine.
Because the yang.guang5@xxxxxxxxxx can't send email out. So I use the
gmail to send.

Thanks.

On Wed, Nov 03, 2021 at 03:14:14PM +0000, Kieran Bingham wrote:
> Hi David,
> 
> Is this patch something you discovered somewhere and have posted on
> behalf of Yang Guang?
> 
> Have you made any modifications to it that would require your sign off?
> or is it simply a repost of a patch you came across?
> 
> Quoting davidcomponentone@xxxxxxxxx (2021-11-03 08:33:37)
> > From: Yang Guang <yang.guang5@xxxxxxxxxx>
> > 
> > Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid
> > opencoding it.
> > 
> > Signed-off-by: Yang Guang <yang.guang5@xxxxxxxxxx>
> 
> The change itself looks fine to me though.
> 
> Reviewed-by: Kieran Bingham <kieran.bingham+renesas@xxxxxxxxxxxxxxxx>
> 
> > ---
> >  drivers/media/pci/saa7134/saa7134-video.c | 6 ++----
> >  1 file changed, 2 insertions(+), 4 deletions(-)
> > 
> > diff --git a/drivers/media/pci/saa7134/saa7134-video.c b/drivers/media/pci/saa7134/saa7134-video.c
> > index 374c8e1087de..6f4132058c35 100644
> > --- a/drivers/media/pci/saa7134/saa7134-video.c
> > +++ b/drivers/media/pci/saa7134/saa7134-video.c
> > @@ -823,7 +823,7 @@ static int buffer_activate(struct saa7134_dev *dev,
> >  {
> >         struct saa7134_dmaqueue *dmaq = buf->vb2.vb2_buf.vb2_queue->drv_priv;
> >         unsigned long base,control,bpl;
> > -       unsigned long bpl_uv,lines_uv,base2,base3,tmp; /* planar */
> > +       unsigned long bpl_uv, lines_uv, base2, base3; /* planar */
> >  
> >         video_dbg("buffer_activate buf=%p\n", buf);
> >         buf->top_seen = 0;
> > @@ -869,9 +869,7 @@ static int buffer_activate(struct saa7134_dev *dev,
> >                 base2    = base + bpl * dev->height;
> >                 base3    = base2 + bpl_uv * lines_uv;
> >                 if (dev->fmt->uvswap) {
> > -                       tmp = base2;
> > -                       base2 = base3;
> > -                       base3 = tmp;
> > +                       swap(base2, base3);
> >                 }
> >                 video_dbg("uv: bpl=%ld lines=%ld base2/3=%ld/%ld\n",
> >                         bpl_uv,lines_uv,base2,base3);
> > -- 
> > 2.30.2
> >



[Index of Archives]     [Linux Input]     [Video for Linux]     [Gstreamer Embedded]     [Mplayer Users]     [Linux USB Devel]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [Yosemite Backpacking]

  Powered by Linux