> -----Original Message----- > From: Russell King - ARM Linux [mailto:linux@xxxxxxxxxxxxxxxx] > Sent: Sunday, July 19, 2009 4:13 PM > To: Chaithrika U S > Cc: linux-media@xxxxxxxxxxxxxxx; mchehab@xxxxxxxxxxxxx; > hverkuil@xxxxxxxxx; davinci-linux-open-source@xxxxxxxxxxxxxxxxxxxx; > Manjunath Hadli; Brijesh Jadav; Kevin Hilman > Subject: Re: [PATCH v2] ARM: DaVinci: DM646x Video: Platform and board > specific setup > > On Tue, Jul 07, 2009 at 07:52:57AM -0400, Chaithrika U S wrote: > > diff --git a/arch/arm/mach-davinci/include/mach/dm646x.h > b/arch/arm/mach-davinci/include/mach/dm646x.h > > index 0585484..1f247fb 100644 > > --- a/arch/arm/mach-davinci/include/mach/dm646x.h > > +++ b/arch/arm/mach-davinci/include/mach/dm646x.h > > @@ -26,4 +26,28 @@ void __init dm646x_init(void); > > void __init dm646x_init_mcasp0(struct snd_platform_data *pdata); > > void __init dm646x_init_mcasp1(struct snd_platform_data *pdata); > > > > +void dm646x_video_init(void); > > + > > +struct vpif_output { > > + u16 id; > > + const char *name; > > +}; > > + > > +struct subdev_info { > > + unsigned short addr; > > + const char *name; > > +}; > > 'subdev_info' is far too generic to have in platform header files. > Please rename this to at least vpif_subdev_info. > > Other than that, patch looks fine. OK. I will post an updated patch soon. Regards, Chaithrika -- To unsubscribe from this list: send the line "unsubscribe linux-media" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html