Re: [PULL] http://linuxtv.org/hg/~pinchartl/uvcvideo

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Sun, 18 Jan 2009 21:49:13 +0100
Laurent Pinchart <laurent.pinchart@xxxxxxxxx> wrote:

> Mauro,
> 
> Please pull from http://linuxtv.org/hg/~pinchartl/uvcvideo/
> 
> for the following 3 changesets:
> 
> uvcvideo: replace strn{cpy,cat} with strl{cpy,cat}.

Hmm... instead of this:

+       phys = kasprintf(GFP_KERNEL, "usb-%s-%s", udev->bus->bus_name,
+                        udev->devpath);

You should use, instead:

 usb_make_path(udev, phys, sizeof(phys));

This is easier to read and it should become a standard to fill bus_name on usb
drivers, since it produces a canonical name.


Cheers,
Mauro
--
To unsubscribe from this list: send the line "unsubscribe linux-media" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html

[Index of Archives]     [Linux Input]     [Video for Linux]     [Gstreamer Embedded]     [Mplayer Users]     [Linux USB Devel]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [Yosemite Backpacking]
  Powered by Linux