28.10.2021 12:53, Rafael J. Wysocki пишет:
+/**
+ * struct power_handler - Machine power-off + restart handler
+ *
+ * Describes power-off and restart handlers which are invoked by kernel
+ * to power off or restart this machine. Supports prioritized chaining for
+ * both restart and power-off handlers. Callback's priority must be unique.
+ * Intended to be used by device drivers that are responsible for restarting
+ * and powering off hardware which kernel is running on.
+ *
+ * Struct power_handler can be static. Members of this structure must not be
+ * altered while handler is registered.
+ *
+ * Fill the structure members and pass it to register_power_handler().
+ */
+struct power_handler {
The name of this structure is too generic IMV. There are many things
that it might apply to in principle.
What about calling power_off_handler or sys_off_handler as it need not
be about power at all?
I didn't like much the 'power' either, but couldn't come up with a
better variant. Will change it in v3, thank you.