Hi Geert,
On 03/09/21 14:51, Michael Schmitz wrote:
Hi Geert,
[resending due to bounce]
thanks for your review!
On 03/09/21 00:42, Geert Uytterhoeven wrote:
Hi Michael,
On Sun, Aug 29, 2021 at 5:12 AM Michael Schmitz<schmitzmic@xxxxxxxxx>
wrote:
The 16 bit card support test for the apne.c driver needs a whole
lot of hairy parser code which is already present in the core
PCMCIA code - make use of that instead of duplicating it.
Signed-off-by: Michael Schmitz<schmitzmic@xxxxxxxxx>
Thanks for your patch!
--- a/arch/m68k/Kconfig.bus
+++ b/arch/m68k/Kconfig.bus
@@ -31,6 +31,8 @@ config ZORRO
config AMIGA_PCMCIA
bool "Amiga 1200/600 PCMCIA support"
Can this become tristate?
I suspect it can - though I wonder why it hasn't been made tristate
before. Ah - pcmcia.c needs a little patch to add a MODULE_LICENSE clause.
depends on AMIGA
+ select PCCARD
+ select PCMCIA
This is now forcing PCCARD and PCMCIA builtin instead of modular
in an allmodconfig kernel.
Thanks, that's what I'd been worried about.
How do I make sure CONFIG_PCMCIA gets selected as module as well? I can
select this when CONFIG_APNE is set, from
drivers/net/ethernet/8390/Kconfig, but I'd then have to protect the
cftable parse hook in amiga/pcmcia.c against the case where CONFIG_APNE
is not selected.
Not to mention we need to rename amiga/pcmcia.c to avoid a module naming
conflict.
I think I rather leave pcmcia_is_16bit() in apne.c where I had initally
put it. No other driver uses it, and I avoid mucking around with file
renames. Core PCMCIA code can still be built as modules, as can the APNE
driver.
Cheers,
Michael