Re: [PATCH v7 1/4] m68k: Kconfig - select core PCMCIA support module for Amiga PCMCIA

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi Michael,

On Fri, Sep 3, 2021 at 4:52 AM Michael Schmitz <schmitzmic@xxxxxxxxx> wrote:
On 03/09/21 00:42, Geert Uytterhoeven wrote:
On Sun, Aug 29, 2021 at 5:12 AM Michael Schmitz<schmitzmic@xxxxxxxxx>  wrote:
The 16 bit card support test for the apne.c driver needs a whole
lot of hairy parser code which is already present in the core
PCMCIA code - make use of that instead of duplicating it.

Signed-off-by: Michael Schmitz<schmitzmic@xxxxxxxxx>
Thanks for your patch!

--- a/arch/m68k/Kconfig.bus
+++ b/arch/m68k/Kconfig.bus
@@ -31,6 +31,8 @@ config ZORRO
  config AMIGA_PCMCIA
         bool "Amiga 1200/600 PCMCIA support"
Can this become tristate?
I suspect it can - though I wonder why it hasn't been made tristate
before. Ah - pcmcia.c needs a little patch to add a MODULE_LICENSE clause.
         depends on AMIGA
+       select PCCARD
+       select PCMCIA
This is now forcing PCCARD and PCMCIA builtin instead of modular
in an allmodconfig kernel.
Thanks, that's what I'd been worried about.

How do I make sure CONFIG_PCMCIA gets selected as module as well? I can
select this when CONFIG_APNE is set, from
drivers/net/ethernet/8390/Kconfig, but I'd then have to protect the
cftable parse hook in amiga/pcmcia.c against the case where CONFIG_APNE
is not selected.

That will be fixed automatically by making AMIGA_PCMCIA tristate.
Select from a modular symbol will make the target modular, too.

Not to mention we need to rename amiga/pcmcia.c to avoid a module naming
conflict.

Just including cistpl.o as a module is not an option unfortunately - too
many dependencies.

And I don't think we need CONFIG_PCMCIA_PROBE=Y?

No idea if we need that...

-default y if ISA && !ARCH_SA1100 && !PARISC
+default y if ISA && !ARCH_SA1100 && !PARISC && !AMIGA_PCMCIA

(wondering how many platforms that can use PCMCIA are left, and if
 this can be converted into positive logic?)

Gr{oetje,eeting}s,

                        Geert

-- 
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@xxxxxxxxxxxxxx

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
                                -- Linus Torvalds



[Index of Archives]     [Video for Linux]     [Yosemite News]     [Linux S/390]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux