On Wed, May 6, 2020 at 4:44 AM Nathan Chancellor <natechancellor@xxxxxxxxx> wrote: > > On Tue, May 05, 2020 at 04:19:17PM +0200, Arnd Bergmann wrote: > > clang points out that doing arithmetic between diffent enums is usually > ^ different > > a mistake: > > > > drivers/leds/leds-lm355x.c:167:28: warning: bitwise operation between different enumeration types ('enum lm355x_tx2' and 'enum lm355x_ntc') [-Wenum-enum-conversion] > > reg_val = pdata->pin_tx2 | pdata->ntc_pin; > > ~~~~~~~~~~~~~~ ^ ~~~~~~~~~~~~~~ > > drivers/leds/leds-lm355x.c:178:28: warning: bitwise operation between different enumeration types ('enum lm355x_tx2' and 'enum lm355x_ntc') [-Wenum-enum-conversion] > > reg_val = pdata->pin_tx2 | pdata->ntc_pin | pdata->pass_mode; > > ~~~~~~~~~~~~~~ ^ ~~~~~~~~~~~~~~ > > > > In this driver, it is intentional, so add a cast to hide the false-positive > > Not sure that I would call this a false positive. The warning is correct > that there is a bitwise operation between different enumeration types > but we do not care since we are just using the enumerated type for its > integer value in lieu of a #define VAR value. Right, I meant that the code works as intended and said "false positive" to avoid claiming the driver is broken when this was a deliberate design point. We do want clang to warn about this though as you say, so I can rephrase it to explain that both the driver and the compiler work as intended but they clash in their views of how to do it ;-) > > - reg_val = pdata->pass_mode; > > + reg_val = (u32)pdata->pass_mode; > > Is this cast needed? I don't think there should be warning from going > from an enumerated type to unsigned int. This cast is not needed for warnings, I added it for consistency because it seemed odd to cast only four of the five enums. I can remove if though if you think it's clearer without the cast. There may also be a different solution in completely removing the lm355x_chip_init() function, as it was added at a time when we were converting the last board files into devicetree, and there has never been a board file defining lm355x_platform_data. There is unfortunately no DT support either in it, so I assume we could just remove the driver completely, or change it to use a DT binding similar to Documentation/devicetree/bindings/leds/leds-lm36*.txt LED maintainers, any opinions on this? Arnd