On Fri, May 26, 2023 at 12:54 AM David Gow <davidgow@xxxxxxxxxx> wrote: > > KUnit aborts the current thread when an assertion fails. Currently, this > is done conditionally as part of the kunit_do_failed_assertion() > function, but this hides the kunit_abort() call from the compiler > (particularly if it's in another module). This, in turn, can lead to > both suboptimal code generation (the compiler can't know if > kunit_do_failed_assertion() will return), and to static analysis tools > like smatch giving false positives. > > Moving the kunit_abort() call into the macro should give the compiler > and tools a better chance at understanding what's going on. Doing so > requires exporting kunit_abort(), though it's recommended to continue to > use assertions in lieu of aborting directly. Should we rename it to __kunit_abort() to discourage that? That would match what we do with __kunit_test_suites_init(). Daniel