On 8/20/21 4:25 PM, Mark Brown wrote:
On Fri, Aug 20, 2021 at 12:39:39PM +0530, Amit Kachhap wrote:
On 8/19/21 10:27 PM, Mark Brown wrote:
- ASSERT_NE(0, hwcaps & HWCAP_PACA) TH_LOG("PAUTH not enabled"); \
+ if (!(hwcaps & HWCAP_PACA)) \
+ SKIP(return, "PAUTH not enabled"); \
} while (0)
#define ASSERT_GENERIC_PAUTH_ENABLED() \
May be ASSERT_GENERIC_PAUTH_ENABLED can be replaced with
something like VERIFY_GENERIC_PAUTH_ENABLED
I thought briefly about bikeshedding the name but didn't come up with
anything that was sufficiently better/clearer.
or can be modified like below and instead of failing it skips with a
message
- ASSERT_NE(0, hwcaps & HWCAP_PACA) TH_LOG("PAUTH not enabled"); \
+ ASSERT_NE(0, hwcaps & HWCAP_PACA) SKIP(return, "PAUTH not enabled");
That's what the patch does?
Agree, I saw few other testcases where ASSERT is used along with SKIP.
(tools/testing/selftests/core/close_range_test.c) so this way
ASSERT_GENERIC_* macro will be clear. There will be just an extra
log like "hwcaps & HWCAP_PACA = 0" in this case.
Probably your way is consistent as other tests in arm64 also just
skips due to HWCAP mismatch.