> While at it, also move a 'platform_device_put()' call to the error handling path. How do you think about to use the message “Complete exception handling in stratix10_svc_drv_probe()” in the final commit subject? … > +++ b/drivers/firmware/stratix10-svc.c … > @@ -1043,24 +1043,34 @@ static int stratix10_svc_drv_probe(struct platform_device *pdev) … > + return 0; > + > +put_platform: > + platform_device_put(svc->stratix10_svc_rsu); > +err_free_kfifo: … > return ret; > } Can the label “err_put_device” be more appropriate for the improved function implementation? (Or: Would you like to omit the prefix “err_” for these jump targets?) Regards, Markus