On Mon, Jan 16, 2017 at 10:26 AM, Eric Paris <eparis@xxxxxxxxxx> wrote: > <opinion from irrelevant person> Well, not totally irrelevant, I just reserve the right to ignore Eric if I disagree with him ;) > All of the patches look good to me except most of those which change > the handling of `rc=`. I have a personal style preference for > > rc = -ENOMEM; > val = kalloc(); > if (!val) > goto err; > > vs > > val = kalloc(); > if (!val) { > rc = -ENOMEM; > goto err; > } > > because it saves 1 line and I think the compiler does the right/same > thing. If there is preference among the people active in selinux > developers (like I said, I'm now irrelevant) I guess they win. My preference tends to be the other way around; I think putting the rc assignment in the if block makes the code more readable and that is how I tend to write things. That said, I don't recall ever requiring someone to redo a patch only because of this style nit ... if I did, shame on me. > But certainly a big +1 from me for the array allocation and sizeof() > changes. I do appreciate all the patches, thank you! However, a bit of a warning that it may take me a little bit of time to work my way through reviewing and merging all of them. -- paul moore www.paul-moore.com -- To unsubscribe from this list: send the line "unsubscribe kernel-janitors" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html