On Fri, Nov 25, 2016 at 08:11:44AM -0500, Sowmini Varadhan wrote: > On (11/25/16 16:01), Dan Carpenter wrote: > > I'm pretty sure the Fixes tag is correct. Originally it did: > > > > +iommu_map_fail: > > + /* Interrupts are disabled. */ > > + spin_lock(&iommu->lock); > > + pci_arena_free(&iommu->arena, entry, npages); > > + spin_unlock_irqrestore(&iommu->lock, flags); > > + > > In that case why dont you just do the local_irq_restore > once at the iommu_map_fail label? I thought this way was easier to read. It doesn't really matter? regards, dan carpenter -- To unsubscribe from this list: send the line "unsubscribe kernel-janitors" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html