Am 19.11.2014 13:09, schrieb Dan Carpenter: > On Wed, Nov 19, 2014 at 12:26:45PM +0100, SF Markus Elfring wrote: >> --- a/drivers/base/power/wakeup.c >> +++ b/drivers/base/power/wakeup.c >> @@ -267,8 +267,7 @@ int device_wakeup_disable(struct device *dev) >> return -EINVAL; >> >> ws = device_wakeup_detach(dev); >> - if (ws) >> - wakeup_source_unregister(ws); >> + wakeup_source_unregister(ws); > > In the original code, it's clear that the programmer thought about what > happens when the device_wakeup_detach() returns NULL but in the new code > that's not clear. > > I guess the information is still there in the git archive, but why hide > the good code by covering it with confusing code? > hi, just to add an other point of view ... device_wakeup_detach returns dev->power.wakeup what is never NULL in this case. (not visible here but a few line before exactly this is checked) so this code can be compacted to: wakeup_source_unregister(device_wakeup_detach(dev)); --readability let the maintainer decide this byte-saving vs readability re, wh -- To unsubscribe from this list: send the line "unsubscribe kernel-janitors" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html