Am 30.04.2013 09:24, schrieb Dan Carpenter: > The missing break here means that we always return early and the > function is a no-op. > > Signed-off-by: Dan Carpenter <dan.carpenter@xxxxxxxxxx> > --- > > diff --git a/sound/soc/codecs/wm8994.c b/sound/soc/codecs/wm8994.c > index 14094f5..1eb152c 100644 > --- a/sound/soc/codecs/wm8994.c > +++ b/sound/soc/codecs/wm8994.c > @@ -2882,6 +2882,7 @@ static int wm8994_aif3_hw_params(struct snd_pcm_substream *substream, > default: > return 0; > } > + break; > default: > return 0; > } the patch seems ok, but i would question the wisdom of a nested switch here, obviously the readability suffers and since it is only one case it seems better to be replaced it with if (dai->id != 3) return 0; Please can the maintainer comment on that ? just my 2 cents, wh -- To unsubscribe from this list: send the line "unsubscribe kernel-janitors" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html