On Fri, 2012-09-14 at 10:14 +1000, Stephen Rothwell wrote: > Hi all, > > I have noticed that we use the following paradigm quite a bit theses days: > > config <something > select HAVE_<config1> > > config <config1> > depends on HAVE_<config1> > > or similar > > I was wondering if it would make sense to replace this with: > > config <something > enable <config1> > > config <config1> > depends on enabled > > The advantage of this is that we would not have all the HAVE_ config > names in our .config files and the generated include files. Of course, > if config1 does not depend on "enabled", then the "enable <config1>" > would have no effect (we may want to warn about this). > > Comments? I always hated those HAVE_* configs, especially because they were always a source of confusion when asking someone if something is enabled... Them: "The function tracer doesn't work, I don't see any debugfs files" me: "Do you have FUNCTION_TRACER enabled?" Them: "Yes, I checked" me: "You have *FUNCTION_TRACER* not *HAVE_FUNCTION_TRACER*?" Them: "Oh, no I just have HAVE_FUNCTION_TRACER" BAH! If you can make 'enable' work, I would definitely Ack converting over to it. -- Steve -- To unsubscribe from this list: send the line "unsubscribe linux-kbuild" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html