Hi Arnaud. Thanks for the comments. > > +# Link of vmlinux > > +# $1 - optional extra .o files > > +# $2 output file > > +vmlinux_link() > > +{ > > + local lds=${srctree}/arch/${SRCARCH}/kernel/vmlinux.lds > > +echo srcarch=${SRCARCH} CF=${CFLAGS_vmlinux} > debugging leftover ? yes - will be deleted. > > + > > + local aflags="${KBUILD_AFLAGS} ${AFLAGS_KERNEL} ${NOSTDINC_FLAGS} ${LINUXINCLUDE} ${KBUILD_CPPFLAGS} ${modkern_aflags}" > might be worse splitting that line. I may be able to drop several of the variables, otherwise yes. > > +mksysmap() > > +{ > > + $NM -n $1 | \ > > + grep -v '\( [aNUw] \)\|\(__crc_\)\|\( \$[adt]\)' > $2 > > +} > > + > you don't seem to consistently use #{FOO} vs. $FOO. For arguments I use $FOO for the rest ${FOO} I will fix this up to be consistent. > > +# Update version > > +info GEN .version > > +if [ ! -r .version ]; then > why '-r' specifically ? '-e' might be just enough. I was so before - this part is a copy from the kernel. And there is already enough changes.. > > +# final build of init/ > > +${MAKE} -f ${srctree}/scripts/Makefile.build obj=init > > + > are spaces allowed in `srctree' ? if so, this will break here. Good catch. Sticking "" around should do the trick? I will try to do so. I should also try if it works with spaces - I think not. > > +kallsymso="" > > +kallsyms_vmlinux="" > > + > > +if [ "${CONFIG_KALLSYMS}" != "" ]; then > > + > [ -n "${CONFIG_KALLSYMS}" ] would work too, as well as the other > places where you use the [ "${FOO}" != "" ] syntax. Much more readable - will change. Sam -- To unsubscribe from this list: send the line "unsubscribe linux-kbuild" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html